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PENGANTAR

Dalam panduan ini, kita akan mempelajari cara mengoperasikan software Proteus untuk
membuat skematik dan menjalankan simulasi proses deteksi gas metana hasil pengolahan
biogas yang dapat dilihat melalui LCD 12C dengan mikrokontroler Arduino Uno serta output
buzzer untuk memberi peringatan ke pengguna jika terdapat gas metana di udara.

TERMINOLOGI

PROTEUS

Proteus adalah perangkat lunak simulasi yang banyak digunakan di bidang teknik elektro
untuk merancang dan menguiji sirkuit elektronik secara virtual. Software ini menyediakan alat
untuk menggambar skematik rangkaian, serta simulasi yang memungkinkan mahasiswa
untuk melihat bagaimana rangkaian bekerja tanpa harus membuat prototipe fisik terlebih
dahulu. Proteus juga mendukung pemrograman mikrokontroler, sehingga mahasiswa dapat
menguji kode yang ditulis dalam berbagai bahasa, termasuk C dan Assembly, sebelum
mengunggahnya ke perangkat keras. Fitur-fitur seperti simulasi rangkaian digital dan analog,
serta interaksi dengan perangkat eksternal, menjadikan Proteus sebagai alat yang sangat
berguna dalam proses belajar dan pengembangan sistem elektronik.

Arduino IDE

Arduino IDE (Integrated Development Environment) adalah platform perangkat lunak yang
digunakan untuk menulis, compile, dan mengunggah kode pemrograman ke papan
pengembangan Arduino. IDE ini mendukung berbagai bahasa pemrograman, terutama
bahasa C/C++, yang disederhanakan untuk mempermudah para pengguna dalam
berinteraksi dengan mikrokontroler. Dengan berbagai pustaka (libraries) yang tersedia,
pengguna dapat dengan mudah mengakses fungsionalitas untuk berbagai perangkat keras
seperti sensor, motor, dan modul komunikasi. Arduino IDE juga menyediakan tampilan
antarmuka yang ramah pengguna, memungkinkan mahasiswa untuk fokus pada logika
pemrograman tanpa memusingkan konfigurasi teknis yang rumit.

Tautan penting:
Unduh software Arduino IDE: Arduino IDE

Kumpulan library: Arduino library

Biogas

Energi biogas adalah energi yang dihasilkan dari limbah organik seperti kotoran ternak, atau
limbah dapur seperti sayuran yang sudah digunakan. Limbah-limbah tersebut akan melalui
proses urai yang dinamakan anaerobik digester di ruang kedap udara. Komponen utama dari
energi biogas ini adalah gas metana (CH4) dan karbondioksida (CO2). Kedua gas tersebut
dapat dibakar atau dioksidasi dan melepas energi, dan energi tersebutlah yang dapat
dimanfaatkan manusia untuk kebutuhan sehari-hari. Akan tetapi, besarnya komponen gas
tersebut tergantung pada proses anaerobik dan komposisi dari bahan dasar pembuatan
energi biogas. Semakin besar kandungan metana dari energi biogas, maka akan semakin
besar juga energi yang bisa dihasilkan dari biogas tersebut.


https://www.arduino.cc/en/software
https://docs.arduino.cc/libraries/

Biogas system
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LCD I12C

LCD 12C (Inter-Integrated Circuit) adalah modul layar kristal cair (LCD) yang menggunakan
komunikasi 12C untuk berinteraksi dengan mikrokontroler. Berbeda dengan LCD standar, LCD
I2C membutuhkan hanya dua pin untuk komunikasi data (SDA dan SCL), yang memudahkan
koneksi dengan papan pengembangan seperti Arduino. Modul LCD 12C ini sangat cocok
digunakan dalam proyek-proyek yang membutuhkan tampilan informasi secara efisien,
seperti pengukuran sensor atau status sistem. Dengan mengurangi jumlah pin yang
diperlukan, mahasiswa dapat fokus pada pengembangan aplikasi tanpa terganggu oleh
keterbatasan input/output pada mikrokontroler.

Contoh penggunaan LCD ke Arduino

Contoh penggunaan LCD dengan tambahan modul 12C ke Arduino



Sensor MQ-4

Sensor MQ-4 adalah bagian dari MQ sensor family yang berfungsi untuk mendeteksi gas
metana. Sensor ini terdiri dari 4 pin yaitu VCC, AQ, DO, dan GND.

Without further ado, let’s get started.

Bahan:

Software Proteus 8.15

Software Arduino IDE (di sini menggunakan versi 1.8.15)
Library LCD 12C Arduino

Library sensor gas untuk Proteus



Library Sensor Gas

Sebelum mulai membuat project, kita memerlukan library sensor gas.
Untuk mendapatkan library tersebut, kunjungi tautan berikut:

Gas sensor library for Proteus

Unduh dan extract berkas .rar tersebut hingga muncul ketiga file seperti di gambar.

~ Along time ago
‘ GasSensorsTEP.IDX

‘ GasSensorsTEP.LIB

‘ GasSensorTEP.HEX

Copy ketiga file tersebut, lalu paste ke folder library seperti yang di gambar.

& > -+ Llocal Disk(C:) > ProgramData > Labcenter Electronics > Proteus 8 Professional >

-’

W Datashests
W Downloads

| I LIBRARY

Il Library Indexing


https://images.theengineeringprojects.com/document/main/arduino/Gas%20Sensor%20Library%20for%20Proteus.rar

Membuat Proyek di Proteus

Buka software Proteus 8.15 yang telah terpasang di PC/laptop masing-masing.
Lalu buat proyek baru dengan menekan tombol New Project

PROTEUS DESIGN SUITE 8.15

k.and PCH (Basic) [Open Project| New Project New Flowshart Open Sampls

ic and PCH {Advanced)
n

Kemudian beri nama proyek tersebut.

Project Name

Recent Projects

Name Biogas Metana Detektorpdspri

Path C:\Users\x390\Documents
Tekan Next, lalu pilih Default.

| % New Project Wizard

O Do not create a schematic.
o Create a schematic from the selected template.

1+ | Design Templates

Landscape A0
Pilih Do not create a PCB layout.

® New Project Wizard

© Do not create a PCB layout.
() Create a PCB layout from the selected template.

‘ Layout Templates

Lalu pilih No firmware project

# New Project Wizard

F

o No Firmware Project
O Create Firmware Project
() Create Flowchart Project

Kemudian, kita akan masuk ke dashboard pembuatan skematik Proteus.



Membuat Skematik Rangkaian

Langkah pertama dalam membuat skematik adalah memasukkan komponen. Arahkan
cursor mouse ke Component Mode seperti gambar di bawah ini:

—l*l- Schematic Capture

B|M oevices

Kemudian akan muncul pop-up menu untuk mencari komponen yang diinginkan. Arahkan
kursor mouse ke menu Keywords, lalu ketik komponen yang dicari.

* Pick Devices

Kerywtnds: Showing ocad results: 16 Prevdiow

acduno Device Liteary Description VEMOLL Mool IS 0LLY
Match whole words? ARDUING MEGA 2560

ArdunoMegaZSEOTER  Arduino MEGA 2560 { Designed by waw. 1
Shaw only parts with models? ARDUINO MEGAZ560 R ArduinoMega2560TEP  Arduino MEGA 2560 R3 ( Designed by ww

Catagory ARDUING NANO ArdudroNana TEP Arduino Nano { Designed by www.ThekEng %‘
ARDUINO NANO R3 ArduinoNanoTEP Arduino Nano R3 [ Desigred by www. Thel !!

(Al Cotegaries) ArduralinaTEP Arduing UND [Desigr by www That ngl E"

Connectors ARDUINO UNO R3 ArduinoUnoTEP Arduino UNO R3 (Desigrad by www Thet : §

Speakers & Sounders ARDUINO-DIL36 CONNOW 36-pin dual-n-kne male header, 100th pite :

www. TheEngineerngProjects. ARDUINO-SILYO CONNDVC 10-pin strig male header, 100eh pitch 53
ARDUINO-SILE CONNDWC G-pin stnp male header, 100th pitch. . §

e ARDUINO-SILS CONNDVC 8-pin s1rip maks header, 100th pitch
Subr-categary: ARDUINO ALIDIO ACTIVE Audio Element of Arduino WAVE Shieid bi POB Preview

Klik komponen yang diinginkan lalu tekan tombol OK, atau klik nama komponen dua Kkali.
Lakukan hingga semua komponen terkumpul.

Komponen sensor gas untuk mendeteksi gas metana adalah sensor mg-4
Koywords: Showing local resuts: 8

gas sensof Densicon

Preview
Uiy Desoriphion O
§ MQ-4 meere wps

Match whole wooss? MG -2 GAS SINSOR
MGQ-3 GAS SENSOR

GusSensarsTEP  MQ-2 Gas Sensor

Stow only parts with modole? GasSensarsTEP MOQ-2
Lategory

(Al Categaries)

MG-5 GAS SENSOR  GasSensansTEF - MQ-5 Gas Sansor

MQDGAS ! ooy Al

) 2t (X} [ ENSOR
Archina MGT GAS ! 1y EQes e (ot B Protessicrand i .
MQ 8 GAS ! s Conmdet ) 1t
MQAGAS ! o \rduinge
A ale
Mol " g
Sus-catogory e X =

(A4 Sub-categanes)



Komponen LCD16x2

Keywords; Showing local results: 153 Preven
| | | Derce Lrwy Twecrpbon A VEM DAL Modw [LEDALPHA]
Match weie words? ] [LMAIEC DXSPLAY 162 AlghanumenclCO_________]
|LMOIL DSPLAY 322 Alphanumenc LCO
Sout ocy perts wemadee? (1|, o1 DISPLAY 402 Alphanumesic LCD
Cawegoryi | oo DISPLAY 16¢1 Alphanumeric LCD
(All Categones) iLMD}l). DSPLAY 2052 Alphanumenic LCO
Analog iCs (2018 DISPLAY 16xd Alphanumenc LCO
CMIOS A0 senes | LMosa DISPLAY 20v4 Alphanumeric LCD
Miraprocesser ICs |LM3228 DISPLAY 126x64 Graphical LCD
Optoelectronics |LM222% DSPLAY 230x 122 Graphical LCD
TTL 744C zerves LMa267 DeSPLAY 24004 Graphecat LCD
[1m3283 DISPLAY 240464 Graphic s LCD $3% od. eanmivas
|Lh287 DISPLAY 24064 Graphical LCD. SRR g s Am Ay
LML ANALOG Linear Dot/Bar Display Driver (Drives LEDs, LCD
[LM3913 ANALOG Logaenhmic Dot/Bae Display Oriver (Doves LED
LMifG ANALOG VU scaled Dot/Bar Display Driver (Dervws LEDs, |
|Lmm2zs DISPLAY 126x64 Graphecel LCD
LM% DISPLAY 240122 Graphical LCD

Komponen 12C

PCF2570 12CI0 256 x 3-bit static low-voltage RAM wi...

|PCF85?4 12C10 Eem ote 8-bit I/ expander for 12C-bus I
PCF35744 12C10 Remote 8-bit I/0 expander for 12C-bus

PCF2375 12CI10 Remote 16-bit IO expander for I2C-h. .

Komponen logicstate

Kerywords:
logicstate

Match whole words? |

Showing local results: 1

Show only parts with models? .|

Category:
{All Cateqories)
Debugging Tools

Sub-category:
(All Sub-categocies)

Device

LOGICSTATE

Ubrary

ACTIVE

Komponen buzzer, pastikan memilih buzzer aktif bukan yang generic.
Showing local resclts: 2

Keywurds:

Dugzzer

Match whole woede? |

Show onily parts with modats?
Catogery

(Al Categaries

Speacers & Soundes

Devica
' IBUZZER

Lbrary
DEVICE

Description

Proview
Description Dt Pastwe RTDSTATE}
Logic State Source (Latched Action)
PCB Preview
Proviow
Gomernan Mo (WUTT R

Gererc buzzer symbol

Komponen transistor NPN



Keywords:
Lren transistor Descripsan A
Match whole words? [ ; NEM433 SEMIIPCTIS1T  TRANS NPN OSC FT=2GHZ SOT-23
Show Y with 'O .M:N EE\’ICE_ G_e_n:nc NPNTbvpo?uvlunmtov
Congacys: _|osTocoum DEVICE Genenc optocoupler with NPN transistor cutput
(All Categories) {PN2222 FARCHLD Séicon NPN Low Power High Frequency Bipolar Trans
Modelling Prmitives | PN2222A FARCHLD S#con NPN Low Power High Fregquency Bipolar Tan:
Optoelectromc j PN2369 FARCHLD Sdicon NPN Low Power Bipolar Transistor {625mW, 12
Tansistors | PN2363A FARCHLD Slicon NPN Low Power Bipoler Transistor (625mW, 12
| PN2484 FARCHLD Sdicon NPN Low Power Bipols Transistor (600mwW, 1!
| PN3S6S FARCHLD Sdicon NPN Low Power Bipolar Transistor (600mW, 1
| PNIBA2 FARCHLD Slicon NPN Low Power High Frequency Bipolar Tran:
| PN3B43 FARCHLD Sdicon NPN Low Power High Freguency Bipolar Tran:
| PN3646 FARCHLD Bipolar NPN Transistor (600mW, 150°C)
jPNJNl FARCHLD Sicon NPN Low Power High Fréquency Bipolar Tans
19&!17 FARCHLD Bipolar NPN Transistor (600mW, 150°C)
| PNS132 FARCHLD Sdicon NPN Low Power High Frequency Bipolar Trans

Tampilan setelah semua komponen terkumpul.
1 Schematic Capture X
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Lalu klik kiri nama komponen dan arahkan kursor mouse ke worksheet.

0 i

Prevew
Anaogus Peestios INPN|
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Jika berhasil, akan tampil seperti gambar berikut
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N1d }esay

AREF

PBS/SCK

PB4/MISO

~ PB3MOSIOC2A
~PB2/OC1B
~PB1/OC1A
PBO/ICP1/CLKO
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PCO/ADCO 8
PC1/ADC1 =
PC2/ADC2
PC3/ADC3
PC4/ADCA4/SDA
PC5/ADCSH/SCL

PD7/AIN1
~ PDT/AIN1
~ PD5/T1/0C0B
PDATOXCK
~ PD3/INT1/0C2B
PD2/INTO
PDATXD
PDO/RXD
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ARDUINO UNO
Ulangi hingga semua komponen ke worksheet. Kemudian, hubungkan tiap komponen
dengan wire. Arahkan kursor mouse ke ujung pin komponen, klik, lalu tarik ke arah pin yang
dituju.

EDIT BUZZER

Setelah menempatkan komponen buzzer, ganti operating voltagenya ke 5V. Klik kanan
buzzer lalu pilih Edit Properties.

"I* Drag Object
Edit Properties Ctrl+E

x Delete Object
Pada bagian operating voltage, ubah 12V menjadi 5V.




# Edit Component

Part Beference:
Part Malue:

Element:

LISA Madel File:
Operating Voltage:
Load Resistance:

Frannenmr

Edit sensor MQ-4

BUZ1

BUZZER

BUZZER

5V

12

500Hz

? X
Hidden: [ | Help
Cancel
Hide Al v
Hide Al w
Hide Al v
Hide Al w

Langkah selanjutnya adalah edit properties pada sensor MQ-4 untuk memastikan sensor
tersebut berjalan lancar saat simulasi di Proteus.

Klik kanan sensor MQ-4 lalu pilih Edit Properties.

"” Drag Object

Edit Properties Ctrl+E

x Delete Object
Pada bagian Program File, pilih ikon folder.

Part Reference: GAS1 Hidden: [
Part Value: MQ-4 GAS SENSOR Hidden: [
Element: Mew

URL: www.TheEngineeringProjects.com  Hide All i
Program Fie: _\\\ProgramDatalLabcenter EI[ &3] Hide Al ~
NAME: MQ-4 Gas Sensor Hide All ~

I me AR in

Hida All

Hidden Pins

Edit Firmware

Cancel

Lalu masuk ke folder library seperti langkah “Library Sensor Gas” di atas. Pilih
GasSensorTEP.HEX lalu tekan tombol Open.



® Sclect Fle Name

Lock o 3~
. e DSRSRRC T _—
‘B | [ GasSonsor EP HEX 5/2/2016 3:55 PM HEX Fila
Home | SoilMostueSensor TEP HEX 11/6/2028 7:17 AM HEX File
Desktop
Librares
This PC
Network
Flenims GasSansaTEP HEX  pen
Filgs of type HEX_UBROF COFF ELF ot 082 Fos Cancel
Setelah terpasang dengan benar, tekan tombol OK.
Part Reference: Hidden: [
Part Value: MQ-4 GAS SENSOR Hidden: (L] | Hidden Pins
SEEL : DS Edit Firmware
URL: www.TheEngineenngProjects.com  Hide All ™ Cancel
Program Fie: \\\ProgramDatalLabcenter EI[ 5| Hide Al ~
NAME: MQ-4 Gas Sensor Hide All v
(W o TP in Hida All ~




Wiring komponen LCD 12C.
LCD 16X2

LMO16L

PD1/TXD

PDO/RXD

PD2/INTO

KOMPONEN [2C

1; SCL PO g
SDA P12
P2
L N b P3 [
< P4
30 1 10
égé I P P7 |12
(]
o8 PCrE574

Wiring sensor MQ-4

Komponen logicstate terhubung ke TestPin, pin OUT dari sensor MQ-4 terhubung ke pin AO
Arduino Uno.

www.TheEngineeringPrd
[

GAS1

MQ-4 GAS SENSOR N JETEVE
[F{)

Reast BTH




Wiring buzzer dan transistor NPN

ADT

1

Komponen POWER dan GROUND T bisa kita ambil di sini:
"

P -

'*' L&A EL

;[r [ TERMINALS
DEFAULT

1F linpuT




Wiring keseluruhan
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Pemrograman Arduino IDE

Buka program Arduino IDE, dalam panduan ini versi yang digunakan adalah versi 1.8.19.
Pilih File -> Preferences
File Edit Sketch Tocols Help

Mew Ctrl+M

Open... Ctrl+0

Open Recent ]
Sketchbook >
Examples >
Close Ctrl+W

Save Ctrl+5

Save As... Ctrl+5hift+5

Page Setup  Ctrl+5Shift+P

Print Ctrl+P
I Preferences  Ctrl+Comma I
Chunt Ctrl+

Centang compilation.
Preferences

Settings  Metwork

Sketchbook location:
C:\Users\Elekiro\Documents\Arduino

Editor language: System Default

Editor font size: 12

Interface scale: Automatic | 100 - %
Theme: Default theme (requires

] upload

Show verbose output during:

Compiler warnings:
Pilih File -> New atau gunakan shortcut CTRL + N.

File Edit Sketch Tocols Help
Mew Ctrl+M

Pilih menu Tools -> Board. Pilih Arduino AVR -> Arduino Uno



Tools Help

Auto Format Ctrl+T
Archive Sketch

Fix Encoding & Reload

Manage Libraries... Ctrl+Shift+|
Senial Monitor Ctrl+Shift+ M
Serial Plotter Ctrl+Shift+L

WiFI101 f WiFiNIMNA Firmware Updater

Board: "Arduino Uno" Boards Manager...
Port Arduino &VR Boards  : Arduino Yin
Get Board Info ESP8266 Boards (3.02) 1| @ Arduino Uno

Dalam panduan ini, kita memerlukan library LCD 12C.

Pasang library LiquidCrystal_12C dengan menekan menu Sketch -> Include Library ->
Manage Libraries

Sketch Tools Help

Verify/Compile Ctrl+R
Upload Ctrl+U

Uplead Using Programmer  Ctrl+Shift+ L
Export compiled Binary Ctrl+Alt+5

Show Sketch Folder Chrl+ K A
Include Library \ Manage Libraries... Ctrl+Shifts|
Add File..

Cviri 22 Add ZIP Library...

Isi kolom pencarian dengan “liquidcrystal i2c”, lalu install.
&) Library Manager

Type Al w | Topic Al w | |liquidcrystal i2c

LiquidCrystal 12C
by Marco Schwartz Version 1.1.2 INSTALLED

A library for 12C LCD displays. The library allows to control I12C displays with functions extremely similar to LiquidCrystal library.
THIS LIBRARY MIGHT NOT BE COMPATIBLE WITH EXISTING SKETCHES.
Mare info

Select version Install

Setelah terpasang, pilih menu Sketch -> Include Library -> LiquidCrystal 12C.




Sketch Tools Help
Contributed libraries

Verify/Compile Ctrl+R )
Adafruit AD51X15
Upload Ctrl+U o
Adafruit Circuit Playground

Upload Using Programmer  Ctrl+Shift+ U

_ _ Adafruit ESPE266
| Export compiled Binary Ctrl+Alt+5 o
i Adafruit Unified Sensor |
Show Sketch Folder Chrl+K Blynk
Include Library : DHT sensor library
Add File.., LiquidCrystal 12C |

Maka akan muncul
#include <LiguidCrystal T2{.h>
Tambahkan juga library bernama Wire.h dengan cara menyisipkan #include <Wire.h> di

sketch, dan spesifikasi LCD 12C yang kita pakai. Karena kita memakai LCD jenis 16x2,
maka:

#include <LiguidCrystal T2{.h>
#include <Wire.h>
LignidCrystal I2C lcd({0x27, 1§, 2);

Kemudian void setup
viold setup() {
led.begin{la, 2);
pinMode (MQPin, INFUT FULLUF) ;
pinMode {(buzzer, OUTEUT);
led. setCursor (3, 0);
led.print {("DETEETOR™) &
led.setCursor {3, 1)
led.print {("GAS METANL™):
delay {1000} ;
led.cleze () s

Dan void loop



vold loop() {

int gas_walue = digitalRead (MQPin);

if (gas_walue==HIGH)

{
digitalWrite{buzzer, HIGH):
led.setCursor{e, 0);
led.print ("GRAS™);

led.setCursor (3, 1):

led.print ("TERDETEESI™) ;
delay {200} ;
led.clear();
delavy {200}

]
M —
A1}
m

led.cl=ar();

digitalWrite (buzzer, LOW):
}

}

Klik tombol Verify.

Tunggu hingga proses compiling selesai.

Program aman dari error saat muncul tanda Done compiling.

lalu ambil alamat .hex seperti di gambar (contoh)



Kembali ke software Proteus.
Klik kanan pada Arduino UNO lalu pilih Edit Properties.

ARD1

‘-I" Drag Object
IEdit Properties Ctrl+E

#<| Delete Object

Paste alamat .hex tadi, lalu tekan tombol OK.

[ARD1 | Hidden: (] | ok |

|;’-‘-.HDL|INO LMD | Hidden: Hidden Finz
ED Edit Firrnware

www. TheEngineerngProjects.com ide All ki Cancel

||4_585006/anemometerino hex | Sl | Hide Al w
[16MHz | Hide Al v

Jalankan simulasi di Proteus, arahkan kursor mouse ke pojok kiri bawah. Tekan tombol play

seperti di gambar.

ITI I’ " o 8 Messag... Root sheet 1

Simulasi berjalan normal saat tidak ada pesan error yang muncul.

P I Il B | @ 4Messagels) | ANIMATING: 0.600000000s {CPU load 99%)

Tampilan simulasi saat awal dijalankan, LCD 12C menampilkan teks pembuka berupa
‘DETEKTOR GAS METANA” dan komponen logicstate yang masih bernilai O.



, BUZ1
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Tampilan saat logicstate aktif dan bernilai 1. LCD 12C akan menampilkan teks “GAS

TERDETEKSI” dan buzzer akan berbunyi.

BUZ1

—
www. [heEnginearingProjects.com
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LAMPIRAN

#include <Wire.h>
#include <LiquidCrystal I2C.h>
LiquidCrystal I2C lcd(0x27,16,2);

#define MQPin A0

#define buzzer 1

setup () |

lcd.begin(l6, 2);

pinMode (MQPin, INPUT PULLUP) ;

pinMode (buzzer, OUTPUT) ;
lcd.setCursor (3, 0);
lcd.print ("DETEKTOR") ;
lcd.setCursor (3, 1);
lcd.print ("GAS METANA") ;
delay (1000) ;
lcd.clear () ;

loop () {
gas value = digitalRead (MQPin) ;
1f (gas value==HIGH)
{
digitalWrite (buzzer, HIGH) ;
lcd.setCursor (6, 0);
lcd.print ("GAS") ;
lcd.setCursor (3, 1);
lcd.print ("TERDETEKSI") ;
delay (200) ;
lcd.clear();
delay (200) ;
}
else
{
lcd.clear ()
digitalWrite (buzzer, LOW) ;
}
}




